YouTube bbcodes not working on old posts

Topics about or relating to the forum itself and how it's run.
Post Reply
User avatar
Allan
Posts: 932
Joined: 30 Aug 2003 20:44
Location: Victoria BC

YouTube bbcodes not working on old posts

Post by Allan » 20 Jul 2012 14:45

This is an issue :( Of all the things that could have gone wrong, this is probably the best case scenario, but still, it wasn't a perfect transition.

A brief history: We were on phpBB2. bbcodes are implemented a certain way on that system. We upgraded to phpBB3. It is not documented that, because bbcodes are implemented totally differently in phpBB3, if you don't re-create your bbcodes before you upgrade, then none of the existing bbcodes will work. I didn't recreate the bbcode before the upgrade.

Not all hope is lost. There is a tool. It allows admins to reprocess bbcodes in existing posts. Unfortunately, this tool is buggy, and it doesn't help that there are many, many posts. When I run the tool to just re-process everything, it won't complete. I've tried it a couple dozen times, and it just keeps crashing. The tool does accept a string of topic IDs to reprocess specific posts. I went through and manually copied all the IDs from the first page of the video section and the footblogs (though I think I stopped short on the footblogs) and reprocessed them. That seems to have worked for those posts. Still, there are many hundreds if not thousands of posts that have bbcode videos in them that are no longer showing up properly.

I am going to continue to work to find a proper solution to this issue that gets all codes in all posts working again. In meantime, I'm going to spend a bunch of time and try to bandaid things as well as possible and get at least the first page from each forum reprocessed manually (if you can help me with this, please speak up! I need the IDs of each post in a string such as: 10023,31200,32455,23455,16777,33440). As well, if you are the owner of a post that has unprocessed bbcode in it, you can simply edit the page (you don't have to change anything) and save it and the code will start working. New posts shouldn't have any issues.

Questions? Volunteers?

User avatar
rjadamson
Multidex Master
Posts: 321
Joined: 17 Jul 2011 21:18
Location: Seattle, WA, USA
Contact:

Re: YouTube bbcodes not working on old posts

Post by rjadamson » 28 Jul 2012 22:25

I will try to help with this. Just to clarify -- the ID for this thread would be 23089? And I can just give you numbers like this?

User avatar
Allan
Posts: 932
Joined: 30 Aug 2003 20:44
Location: Victoria BC

Re: YouTube bbcodes not working on old posts

Post by Allan » 29 Jul 2012 13:49

rjadamson wrote: the ID for this thread would be 23089? And I can just give you numbers like this?
Yes and yes :) Thanks! I've been very lazy about actually doing this.

Post Reply